Posted on Oct 21 2014 - 11:49pm by Anurag Kumar

Google has replaced stock messaging app with its new Messenger app in Android 5.0 Lollipop. It has a new material design look which goes with Android 5.0 Lollipop system UI. It is very simple app when it comes to features and UI; attaching media in the messages now is easier with one tap and you will find different color settings of each conversation.

Google’s new SMS/MMS messenger app from Android 5.0 Lollipop is now unofficially available for download and it is working great on non rooted devices running android 4.4 KitKat. We have tested it on our Xperia Z2 and it works great and it should work with all android 4.4 running devices.

Google Messenger app from Android 5.0 Lollipop

Download Google Messenger apk from below and install normally on your device. No root needed, confirmed working on all Xperia android 4.4 devices, compatibility with android 4.3 unknown. Google Messenger version 1.0.041 apk attached below.

Download Messenger.apk

Google Messenger app from Android 5.0 Lollipop

Google Messenger apk  from Android 5.0 Lollipop

Download Google Messenger app version 1.0.041

Let us know if you like the app. Drop your comments below.

via – Matthew Baer Google+






About the Author

An Internet Marketer-Infopreneur-Passionate Blogger-Technopreneur-Impatient Optimist! He is an MBA (IB) from IIFT Delhi (2015-17). He is the Founder & Editor-in-Chief of GizmoBolt.com ( formerly XperiaGuide.com ). Follow him at Facebook I Twitter I Google Plus | LinkedIn | Instagram. Contact him at [email protected] for feedback and sending tips. Donate Us.

6 Comments so far. Feel free to join this conversation.

  1. m.m October 22, 2014 at 4:06 pm - Reply

    Thank you, dear colleague and supporter of Sony

  2. Ruzhella October 22, 2014 at 5:19 pm - Reply

    No emojies available yet 🙁

  3. NiuginiNexus October 26, 2014 at 2:25 am - Reply

    What he said – not a single emoji.

  4. jhulz November 1, 2014 at 4:02 pm - Reply

    Force closed when i write new SMS 🙁

  5. muthu December 5, 2014 at 3:54 pm - Reply

    celkon a35k android 4.4.2kitkat but google messenger installed not open package error or invalid package

  6. rodny December 7, 2014 at 8:49 am - Reply

    Is this possible for ICS users? i mean, can this be ported to any ICS devices? THANKS! 🙂

Leave A Response

*